Quantcast
EQ2Interface.com
Search Downloads


Go Back   EQ2Interface > Interface Pieces > Casting / Breath Bar

Category: Casting / Breath BarSorakUI Casting Window (SMALL)
Interface Information
Download
How do I install this? (FAQ)
Name: SorakUI Casting Window (SMALL)   Popular!
Author:
Date: 10-18-2005 06:27 AM
Size: 31.26 Kb
Version: 1.0.0.1
Rate Addon: 5 out of 5 with 3 votes  
Patch & Add-on List
File Name
Version
Size
Author
Date
Type
1.1
1.01 Kb
01-13-2009 10:38 PM
Patch
Pictures
Click to enlarge 

Views: 3936
Size: 5.94 Kb
Dimensions: 155 x 180
Small Casting orb. The target is for comparison
 
Description
This is a smaller version of my original casting orb.

Update: Fixed Inventory full text to wrap in the whole window.
Now includes the correct zip file.

Enjoy!

Sorak
File Statistics
User Rating:
5 out of 5 with 3 votes
Downloads: 2292
Views: 20074
Favorites: 14
Uploaded By:
 
Last Modified: N/A

View Pictures. Download Now! Post A Comment


Post A Reply
Author Comments Comment Options
Unread 03-21-2011, 12:43 PM  
GamingKatze
A Coastal Crab

Server: Unkown
Forum posts: 0
File comments: 2
Uploads: 0
Talking Re: A-HA!!! No more white background!!!

Quote:
Originally posted by hobert
Well, after getting extremely fed up with the white box, I decided to go back and read up on all the XML changes that occured to the equi_mainhud_casting.xml file and see if I could update it and get it to work. Yeppers!!

Here's the updated XML file (sorry, no idea how to attach it as a file). Changes/additions are in red, if you want to edit your own. There are four, including a swap of a "\" with a "/"!

Code:
<?xml version="1.0" encoding="utf-8"?>
<Page DynamicData="/GameData.Spells.Window" DynamicDataFilter="0001" eq2usescomwndcontrols="true" Location="282,29" Name="Casting" PackLocation="center,bottom" PackLocationProp="-230/0001,-739/0001" ScrollExtent="171,127" Size="171,127" UserMovable="true">
<Page AbsorbsInput="false" DynamicData="/GameData.Spells.Failure" DynamicDataFilter="0001" Location="0,1" Name="CastingFailure" PackLocation="left,top" PackLocationProp="0000/0001,0001/0001" PackSize="absolute" PackSizeProp="0000/0001,xxxx/xxxx" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="171,124" Size="171,124">
<Text AbsorbsInput="false" DynamicData="/GameData.Spells.Failure" Font="/TextStyles.OnscreenMsg.OnscreenMsgStyle" LocalText="[DEVL]Interrupted!" Name="Text" ScrollExtent="169,127" ShadowStyle="/ShadowStyles.Outline1" Size="169,127" TextAlignment="Center" TextAlignmentVertical="Center">:8d7f373294c57d99:[DEVL]Interrupted!</Text>
</Page>
<Page AbsorbsInput="false" BackgroundColor="#FF0000" DynamicData="/GameData.Spells.Casting" DynamicDataFilter="0001" Location="0,1" Name="CastingProgress" PackLocation="left,top" PackLocationProp="0000/0001,0001/0001" PackSize="absolute" PackSizeProp="0000/0001,xxxx/xxxx" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="171,126" Size="171,126">
<ImageStyle Name="progress_fill">
<ImageFrame Name="progress_fill" Source="images/SorakOrb2.tga" SourceRect="320,232,387,298"/>
</ImageStyle>
<ProgressbarStyle Bar.Background="progress_fill" Layout="Vertical" Name="progress_style"/>
<Text AbsorbsInput="false" DynamicData="/GameData.Spells.Casting" Font="/TextStyles.Large.LargeStyle" LocalText="[DEVL]Fighting Chance" Location="1,2" Name="SpellName" ScrollExtent="168,122" ShadowStyle="/ShadowStyles.Outline1" Size="168,122" TextAlignment="Center" TextColor="#F0D080">:8d7f373294c57d99:[DEVL]Fighting Chance</Text>
<Image AbsorbsInput="false" Location="35,21" Name="ProgressBackground" ScrollExtent="99,103" Size="99,103" SourceRect="127,204,223,308" SourceResource="images/SorakOrb2.tga"/>
<Progressbar AbsorbsInput="false" BackgroundColor="#000000" DynamicData="/GameData.Spells.Casting" Location="48,46" Name="Progress" Progress="0.500" ScrollExtent="65,64" Size="65,64" Style="progress_style"/>
<Image Location="46,32" Name="OrbBackGround" ScrollExtent="70,91" Size="70,91" SourceRect="232,212,291,308" SourceResource="images/SorakOrb2.tga"/>
</Page>
<Page AbsorbsInput="false" BackgroundOpacity="1.000" Name="WC_Frame" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" RStyleDefault="/FrameStyles.single_pixel" ScrollExtent="170,190" Size="170,190" Visible="false"/>
<Page AbsorbsInput="false" BackgroundOpacity="1.000" Name="WC_Backdrop" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" ScrollExtent="168,189" Size="168,189" Visible="false"/>
</Page>
The font changed from the hard coded FontKabosGyula24 to TextStyles.OnscreenMsg.OnscreenMsgStyle, I assume to take advantage of new options you can select in regards to On Screen messages. You may be able to leave it hard coded (I haven't tried).

The addition of :8d7f373294c57d99: before [DEVL]in two places had to do with new localization options (I assume to easily change the language).

Neither of which sounds like it would help with the white box...but I found one tiny little thing that stood out to me...

The line that starts <Image Location="46,32" Name="OrbBackGround", has SourceResource="images\SorakOrb2.tga". Notice the forward slash. Every other locationin a mod I've looked at uses the backward slash. Changing that, I assume, brings back the transparency. I would guess an unlisted (or hard-to-find) change in the coding made \ and / more critical than before, which made the mod start having a white background.

Anyway, hope this helps anyone using this great casting mod!!
Thank you so much for this, it works perfectly. I am very new to modding anything in EQII (I just started last night, literally lol) but this was very easy to understand so thank you for this.

This is a beautiful casting mod, I really adore it, thank you for making this mod!
GamingKatze is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-15-2008, 03:53 PM  
hobert
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
A-HA!!! No more white background!!!

Well, after getting extremely fed up with the white box, I decided to go back and read up on all the XML changes that occured to the equi_mainhud_casting.xml file and see if I could update it and get it to work. Yeppers!!

Here's the updated XML file (sorry, no idea how to attach it as a file). Changes/additions are in red, if you want to edit your own. There are four, including a swap of a "\" with a "/"!

Code:
<?xml version="1.0" encoding="utf-8"?>
<Page DynamicData="/GameData.Spells.Window" DynamicDataFilter="0001" eq2usescomwndcontrols="true" Location="282,29" Name="Casting" PackLocation="center,bottom" PackLocationProp="-230/0001,-739/0001" ScrollExtent="171,127" Size="171,127" UserMovable="true">
<Page AbsorbsInput="false" DynamicData="/GameData.Spells.Failure" DynamicDataFilter="0001" Location="0,1" Name="CastingFailure" PackLocation="left,top" PackLocationProp="0000/0001,0001/0001" PackSize="absolute" PackSizeProp="0000/0001,xxxx/xxxx" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="171,124" Size="171,124">
<Text AbsorbsInput="false" DynamicData="/GameData.Spells.Failure" Font="/TextStyles.OnscreenMsg.OnscreenMsgStyle" LocalText="[DEVL]Interrupted!" Name="Text" ScrollExtent="169,127" ShadowStyle="/ShadowStyles.Outline1" Size="169,127" TextAlignment="Center" TextAlignmentVertical="Center">:8d7f373294c57d99:[DEVL]Interrupted!</Text>
</Page>
<Page AbsorbsInput="false" BackgroundColor="#FF0000" DynamicData="/GameData.Spells.Casting" DynamicDataFilter="0001" Location="0,1" Name="CastingProgress" PackLocation="left,top" PackLocationProp="0000/0001,0001/0001" PackSize="absolute" PackSizeProp="0000/0001,xxxx/xxxx" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="171,126" Size="171,126">
<ImageStyle Name="progress_fill">
<ImageFrame Name="progress_fill" Source="images/SorakOrb2.tga" SourceRect="320,232,387,298"/>
</ImageStyle>
<ProgressbarStyle Bar.Background="progress_fill" Layout="Vertical" Name="progress_style"/>
<Text AbsorbsInput="false" DynamicData="/GameData.Spells.Casting" Font="/TextStyles.Large.LargeStyle" LocalText="[DEVL]Fighting Chance" Location="1,2" Name="SpellName" ScrollExtent="168,122" ShadowStyle="/ShadowStyles.Outline1" Size="168,122" TextAlignment="Center" TextColor="#F0D080">:8d7f373294c57d99:[DEVL]Fighting Chance</Text>
<Image AbsorbsInput="false" Location="35,21" Name="ProgressBackground" ScrollExtent="99,103" Size="99,103" SourceRect="127,204,223,308" SourceResource="images/SorakOrb2.tga"/>
<Progressbar AbsorbsInput="false" BackgroundColor="#000000" DynamicData="/GameData.Spells.Casting" Location="48,46" Name="Progress" Progress="0.500" ScrollExtent="65,64" Size="65,64" Style="progress_style"/>
<Image Location="46,32" Name="OrbBackGround" ScrollExtent="70,91" Size="70,91" SourceRect="232,212,291,308" SourceResource="images/SorakOrb2.tga"/>
</Page>
<Page AbsorbsInput="false" BackgroundOpacity="1.000" Name="WC_Frame" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" RStyleDefault="/FrameStyles.single_pixel" ScrollExtent="170,190" Size="170,190" Visible="false"/>
<Page AbsorbsInput="false" BackgroundOpacity="1.000" Name="WC_Backdrop" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" ScrollExtent="168,189" Size="168,189" Visible="false"/>
</Page>
The font changed from the hard coded FontKabosGyula24 to TextStyles.OnscreenMsg.OnscreenMsgStyle, I assume to take advantage of new options you can select in regards to On Screen messages. You may be able to leave it hard coded (I haven't tried).

The addition of :8d7f373294c57d99: before [DEVL]in two places had to do with new localization options (I assume to easily change the language).

Neither of which sounds like it would help with the white box...but I found one tiny little thing that stood out to me...

The line that starts <Image Location="46,32" Name="OrbBackGround", has SourceResource="images\SorakOrb2.tga". Notice the forward slash. Every other locationin a mod I've looked at uses the backward slash. Changing that, I assume, brings back the transparency. I would guess an unlisted (or hard-to-find) change in the coding made \ and / more critical than before, which made the mod start having a white background.

Anyway, hope this helps anyone using this great casting mod!!
hobert is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-01-2007, 03:19 PM  
Lexi357
A Weald Wolf
 
Lexi357's Avatar

Server: Permafrost
Forum posts: 84
File comments: 17
Uploads: 0
I really liked this mod too, Im getting a white box behind the casting orb...I've no idea when it started but it had to have been recently as I had to do a reformat and start a customUI from scratch.

If anyone has a working stand-alone casting animation besides the default would ya be willing to share it?
Lexi357 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-28-2007, 07:55 AM  
Kattmando
A Young Mystail Rat

Server: Antonia Bayle
Forum posts: 6
File comments: 10
Uploads: 0
I've also re-downloaded the mod and have seen the white and black background when casting, this seems to be based off of different video cards/drivers. However, originally it showed a transparent background. I've updated drivers even rolled back drivers with no change. The symptoms did occur on one of SoE's updates a few months ago and has never been the same since.

Any suggestions or a good direction would be greatly appreciated.
Kattmando is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-21-2007, 11:05 AM  
HonorJim
A Coastal Crab

Server: Antonia Bayle
Forum posts: 1
File comments: 1
Uploads: 0
Re: Great Mod!

Quote:
I adore this simple mod!

Somewhere around late last year, a white box started showing up around the globe...more than likely because of an EQ2 change. Is there any way to get it to go away?

Thanks!
I just got this mod and my box is black, thought it was just the backround but I checked and it has no backround selected. I double checked the file locations the tga is in my eq2/ui/cutomui/images directory and the casting .xml file is in eq2/ui/cutomui directory. so Im pretty sure I installed correctly.
any help would be MOST appreciated.

Jim
HonorJim is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-21-2007, 09:10 AM  
hobert
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
Great Mod!

I adore this simple mod!

Somewhere around late last year, a white box started showing up around the globe...more than likely because of an EQ2 change. Is there any way to get it to go away?

Thanks!
hobert is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-18-2005, 10:44 PM  
scan
A Young Mystail Rat
 
scan's Avatar

Server: Antonia Bayle
Forum posts: 7
File comments: 7
Uploads: 0
OK, I have it now, the file I downloaded must of gotten corrupted somehow. When I downloaded it again, the size of it was bigger. Very sweet mod! Keep up the good work!
scan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-18-2005, 10:27 PM  
scan
A Young Mystail Rat
 
scan's Avatar

Server: Antonia Bayle
Forum posts: 7
File comments: 7
Uploads: 0
Hmm, tried this today, but the globe was gone, nothing there when I harvest etc. Used your prior one with no problems, maybe because one is a .tga and the prior one is a .dds?
scan is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-17-2005, 01:16 PM  
Lucian.jp
A Coastal Crab

Server: Befallen
Forum posts: 1
File comments: 4
Uploads: 0
The file is PlayerSmall instead of CastingSmall think you updloaded the wrong file...
Lucian.jp is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-17-2005, 01:55 AM  
Lucian.jp
A Coastal Crab

Server: Befallen
Forum posts: 1
File comments: 4
Uploads: 0
Seems the red arrow bug was in the default UI fixed in one of the last update sorry... Great mod tho. but still have the "Your inventory is full" bug.
Lucian.jp is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-14-2005, 10:43 PM  
Lucian.jp
A Coastal Crab

Server: Befallen
Forum posts: 1
File comments: 4
Uploads: 0
Quote:
Originally posted by Sorak
Is this happening to your spells on the hotkey? I don't remember them effects on the casting meter.
I'm not a really good UI modder tho but I'm using the same UI for awhile and the 4 little red arrow always worked well. Maybe not in link with the mainhud_casting cause in fact it is not linked and the arrow seems to be same size and same movement. For me it seems it is just the graphics of the arrow that are gone. Is it possible that it is because you use the SorakOrb2.tga images instead of window_elements_generic.dds???

Also notices something : I run EQ2 in 1280 X1024 (don't know if it change something for that bug) When my inventory is full is writes in the casting window. Becasue it is less wider, it only wrote Your inventory is. Is it possible to make it show??
Lucian.jp is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-14-2005, 12:41 PM  
Sorak
A Brown Bear
Interface Author - Click to view interfaces

Server: Faydark
Forum posts: 11
File comments: 7
Uploads: 6
Quote:
Originally posted by Lucian.jp
Really nice... love that one. unfortunatly since I have put this mod, when I upgrade a spell or receive a new one I do not have anymore the 4 little red arrow turning around the spell for 5 seconds it is replaced by 4 white sqare. Really ugly tho.. Hope it will be fixed in next released.
That is odd. This mod should only effect the casting window and its graphics. I do not believe that this effects that as I think them effects are hardcoded into the client. I looked thru the xml and see nothing that hints to an effect like that. I have not seen this when I play and I use all my own mods. Hrmm I am stumped on this one. I would be curious to know if anyone else notices this side effect.

Is this happening to your spells on the hotkey? I don't remember them effects on the casting meter.
Sorak is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-14-2005, 01:10 AM  
Lucian.jp
A Coastal Crab

Server: Befallen
Forum posts: 1
File comments: 4
Uploads: 0
Really nice... love that one. unfortunatly since I have put this mod, when I upgrade a spell or receive a new one I do not have anymore the 4 little red arrow turning around the spell for 5 seconds it is replaced by 4 white sqare. Really ugly tho.. Hope it will be fixed in next released.
Lucian.jp is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-12-2005, 10:59 AM  
Juravael
A Coastal Crab

Server: Antonia Bayle
Forum posts: 1
File comments: 27
Uploads: 0
Very well done!

A extremely well done mod, very smooth and attractive

Looking forward to more from you!
Juravael is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 04:18 PM.


Our Network
EQInterface | EQ2Interface | WoWInterface | LoTROInterface | ESOUI | MMOUI