Quantcast
EQ2Interface.com
Search Downloads


Go Back   EQ2Interface > Interface Pieces > Miscellaneous

Category: MiscellaneousWyntakata's Toon Swapper
Interface Information
Download
How do I install this? (FAQ)
Name: Wyntakata's Toon Swapper   Popular!
Author:
Date: 04-19-2010 02:42 PM
Size: 57.56 Kb
Version: 1.1
Rate Addon: 5 out of 5 with 1 votes  
Pictures
Click to enlarge 

Views: 0
Size: 29.31 Kb
Dimensions: 438 x 441
Macro
 
Click to enlarge 

Views: 0
Size: 20.51 Kb
Dimensions: 329 x 276
ToonSwap Window
 
Description
This is a modification of Mistal's travel hub to create a "Camping" macro for my personal use. The older EQ2 button mods stopped working for me for some unknown reason, I ended up just at char select instead of a proper toon swap.

I had no idea what to do or where to start to make the mod what I wanted until I saw Mistal's travel hub. So I am sorry if I butchered your mod mistal but now I have what I wanted for months hehe.

Anyways I hope the instructions are straight forward enough and that some can get use from this. It still works along side Mistals mods.

All credit to Mistal for providing what I needed

1.1 Now includes a target_self AFK button and tooltips
Archive List (Old Versions)
File Name
Version
Size
Author
Date
1
57.40 Kb
Wyntakata
04-09-2010 12:40 PM
File Statistics
User Rating:
5 out of 5 with 1 votes
Downloads: 2344
Views: 16882
Favorites: 1
Uploaded By:
 
Last Modified: N/A

View Pictures. Download Now! Post A Comment


Post A Reply
Author Comments Comment Options
Unread 08-31-2010, 11:54 AM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Smile Re: Re: GU 57

Quote:
Originally posted by flutieflakes
Oh, I'm SO happy to say I just got this working fine. It turns out that copying and pasting the information as directed into the <include>_eq2_ToonSwap.xml</include> information into the eq2ui_custom.xml was the problem. I had to copy and paste it to the Profitui_custom.xml file to get it to work.
Glad to hear you got it working
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-31-2010, 03:58 AM  
flutieflakes
A Young Mystail Rat

Server: Antonia Bayle
Forum posts: 7
File comments: 4
Uploads: 0
Re: GU 57

Quote:
Originally posted by Wyntakata
I did a clean install of the custom UI I am using due to mini map breaking with the update. Redid eq2maps, reinstalled this mod and it works fine. I know people keep saying they did everything right and it dont work so I am sorry to say if you dont follow the instructions by copying and pasting to eliminate typing errors then something else you are doing is wrong.

After installing it with a custom UI that has a eq2_custom.xml file that gets updated will undo what u did. If the window for this is open while you load the game then something is wrong because it will not and shud not open until u create and click the macro.

Paste exact copies of the contents of ur eq2_custom.xml file and screen shots of the contents of ur image folder and custom ui folder so i can see the files to do with the mod are in the correct place. If u modify what u send to me I cant giv an accurate solution if I dont see what is wrong
Oh, I'm SO happy to say I just got this working fine. It turns out that copying and pasting the information as directed into the <include>_eq2_ToonSwap.xml</include> information into the eq2ui_custom.xml was the problem. I had to copy and paste it to the Profitui_custom.xml file to get it to work.
flutieflakes is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-21-2010, 03:52 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
GU 57

I did a clean install of the custom UI I am using due to mini map breaking with the update. Redid eq2maps, reinstalled this mod and it works fine. I know people keep saying they did everything right and it dont work so I am sorry to say if you dont follow the instructions by copying and pasting to eliminate typing errors then something else you are doing is wrong.

After installing it with a custom UI that has a eq2_custom.xml file that gets updated will undo what u did. If the window for this is open while you load the game then something is wrong because it will not and shud not open until u create and click the macro.

Paste exact copies of the contents of ur eq2_custom.xml file and screen shots of the contents of ur image folder and custom ui folder so i can see the files to do with the mod are in the correct place. If u modify what u send to me I cant giv an accurate solution if I dont see what is wrong
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-18-2010, 12:11 AM  
flutieflakes
A Young Mystail Rat

Server: Antonia Bayle
Forum posts: 7
File comments: 4
Uploads: 0
Re: Re: Same Problem

Quote:
Originally posted by Wyntakata
The mod works on the location of the custom UI folder regardless of where EQ2 is installed it works as if the custom UI folder is the base folder so my only ideas would be that something is typed in lowercase rather then uppercase or there is some incompatabilty with the custom UI.
I followed the instructions to the letter and I still can't make a working macro for it anymore. The ironic thing is that the window pops open while the game is loading, but once I close that window when I get in the game, I'm unable to open it again.
flutieflakes is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-07-2010, 10:09 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Re: Same Problem

Quote:
Originally posted by flutieflakes
Hi, I'm very grateful for this Toon Swap mod and was using it constantly before needing to reformat my computer. Now that I've reinstalled Eq2 and am adding my mods back in, this will not work regardless of what I try. I've read through all the previous poster's notes and have tried those suggestions to no avail. The only difference for me has been that when my new programs installed (EQ2, etc.) they installed into a new directory that they didn't before. Insttead of going to C:/Program Files (x86)/Sony.../Installed Games/Everquest2/..., they are now going to C:/Program Data/Sony.../Installed Games/Everquest2/... (the ellipsis is untyped words to shorten the message). I don't understand why Vista started installing my software like that and don't know how to change it, but could that be why the program isn't working for me. Also of note, when my game is loading (with Profit UI), right after installing, the Toon Swap window will show as open, but once I close it and try to use the macro button, I get nothing. Any ideas?
The mod works on the location of the custom UI folder regardless of where EQ2 is installed it works as if the custom UI folder is the base folder so my only ideas would be that something is typed in lowercase rather then uppercase or there is some incompatabilty with the custom UI.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-07-2010, 09:07 PM  
flutieflakes
A Young Mystail Rat

Server: Antonia Bayle
Forum posts: 7
File comments: 4
Uploads: 0
Same Problem

Hi, I'm very grateful for this Toon Swap mod and was using it constantly before needing to reformat my computer. Now that I've reinstalled Eq2 and am adding my mods back in, this will not work regardless of what I try. I've read through all the previous poster's notes and have tried those suggestions to no avail. The only difference for me has been that when my new programs installed (EQ2, etc.) they installed into a new directory that they didn't before. Insttead of going to C:/Program Files (x86)/Sony.../Installed Games/Everquest2/..., they are now going to C:/Program Data/Sony.../Installed Games/Everquest2/... (the ellipsis is untyped words to shorten the message). I don't understand why Vista started installing my software like that and don't know how to change it, but could that be why the program isn't working for me. Also of note, when my game is loading (with Profit UI), right after installing, the Toon Swap window will show as open, but once I close it and try to use the macro button, I get nothing. Any ideas?
flutieflakes is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-30-2010, 02:26 AM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Re: Re: Re: Re: ToonSwap

Quote:
Originally posted by roglen
Super......

That did it, works like a charm.

Thank you for all the time and trouble shooting on this. It is one very handy add-on.

Sorry for the trouble. Just looked back at your instructions and guess what... the C in Custom is in fact CAPS...DOH.

Maybe I shall learn to read some day if I just keep trying hard (LOL).

Thanks again
Lol np. We all keep learnin. I am glad I actually thought to test that.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-29-2010, 11:03 PM  
roglen
A Coastal Crab
 
roglen's Avatar

Server: Antonia Bayle
Forum posts: 1
File comments: 9
Uploads: 0
Re: Re: Re: ToonSwap

Quote:
Originally posted by Wyntakata
OK ok I just did a test in game. In your posts you said u set up the macro as follows "/show_window custom.eq2_ToonSwap", I tried that and it dont work but this does "/show_window Custom.eq2_ToonSwap" - Spot the difference, small c - big C.
Super......

That did it, works like a charm.

Thank you for all the time and trouble shooting on this. It is one very handy add-on.

Sorry for the trouble. Just looked back at your instructions and guess what... the C in Custom is in fact CAPS...DOH.

Maybe I shall learn to read some day if I just keep trying hard (LOL).

Thanks again
roglen is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-29-2010, 04:57 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Re: Re: ToonSwap

Quote:
Originally posted by Wyntakata
Lol me too. I only butchered someone elses mod to make this.

I just checked my wifes computer as I have it setup there too and the only difference with hers and mine is in the include of the custom file there is no .xml so maybe by chance removing it will allow it to work for you? I dont see why this would work but there must be some difference between the computers.

Only other stuff I can think to suggest is to backup the following files as in move them temporarily to another folder:
eq2_recent.ini
eq2_default.ini
Empty the cache folder and be sure your eq2.ini folder is pointing to the correct ui folder. Even possibly to ui files relating to your toons but that would be a bit extreme i think.

Another thing to possibly try is the macro without the slash show_window Custom.eq2_ToonSwap instead of /show_window Custom.eq2_ToonSwap just copy and past to be sure of no typing errors
OK ok I just did a test in game. In your posts you said u set up the macro as follows "/show_window custom.eq2_ToonSwap", I tried that and it dont work but this does "/show_window Custom.eq2_ToonSwap" - Spot the difference, small c - big C.

Last edited by Wyntakata : 05-29-2010 at 04:57 PM.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-29-2010, 03:23 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Re: ToonSwap

Quote:
Originally posted by roglen
Ok, here is what I did.

Created a new empty ui folder, put only _eq2_ToonSwap.xml in it. Removed everything from the eq2ui_custom.xml and put only your include in it, like this:

<?xml version="1.0" encoding="utf-8"?>
<Page IgnoreTab="false" ismodule="true" Name="Custom" PackSize="1,1" PackSizeProp="0002/0003,0002/0003" ScrollExtent="1024,768" Size="1024,768" Visible="false">
<include>_eq2_ToonSwap.xml</include>
</Page>

Put your Toonswap folder in the images folder.

Logged into the game, double checked the macro /show_window custom.eq2_ToonSwap clicked on the macro and I got the same thing.... which is nothing, no window no command error, nothing.

Deleted the ui.log, logged into the game, hit the macro, and logged back out. This is what I got in the ui.log after logging out:

Couldn't load .xml
Encountered data outside of container tags
Encountered data outside of container tags
Encountered data outside of container tags

What ever that means, lol... I don't know xml at all. I just plug things in where you folks tell me to.
Lol me too. I only butchered someone elses mod to make this.

I just checked my wifes computer as I have it setup there too and the only difference with hers and mine is in the include of the custom file there is no .xml so maybe by chance removing it will allow it to work for you? I dont see why this would work but there must be some difference between the computers.

Only other stuff I can think to suggest is to backup the following files as in move them temporarily to another folder:
eq2_recent.ini
eq2_default.ini
Empty the cache folder and be sure your eq2.ini folder is pointing to the correct ui folder. Even possibly to ui files relating to your toons but that would be a bit extreme i think.

Another thing to possibly try is the macro without the slash show_window Custom.eq2_ToonSwap instead of /show_window Custom.eq2_ToonSwap just copy and past to be sure of no typing errors

Last edited by Wyntakata : 05-29-2010 at 03:57 PM.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-29-2010, 03:08 PM  
roglen
A Coastal Crab
 
roglen's Avatar

Server: Antonia Bayle
Forum posts: 1
File comments: 9
Uploads: 0
ToonSwap

Quote:
Originally posted by Wyntakata
OMG I am at a complete loss I see absolutely nothing wrong. Mine still works fine and as far as I can tell its identical setup to yours. Can you check your UI log file for any clues? It is directly in the eq2 folder, I usually use that when a UI wont load. I assume when u say the _eq2_ToonSwap.xml is in my ui folder you mean the DrumsUI folder?

Oh with the UI file in the eq2 folder if there is too much there just delete it and run eq2 and a new one will be created
Ok, here is what I did.

Created a new empty ui folder, put only _eq2_ToonSwap.xml in it. Removed everything from the eq2ui_custom.xml and put only your include in it, like this:

<?xml version="1.0" encoding="utf-8"?>
<Page IgnoreTab="false" ismodule="true" Name="Custom" PackSize="1,1" PackSizeProp="0002/0003,0002/0003" ScrollExtent="1024,768" Size="1024,768" Visible="false">
<include>_eq2_ToonSwap.xml</include>
</Page>

Put your Toonswap folder in the images folder.

Logged into the game, double checked the macro /show_window custom.eq2_ToonSwap clicked on the macro and I got the same thing.... which is nothing, no window no command error, nothing.

Deleted the ui.log, logged into the game, hit the macro, and logged back out. This is what I got in the ui.log after logging out:

Couldn't load .xml
Encountered data outside of container tags
Encountered data outside of container tags
Encountered data outside of container tags

What ever that means, lol... I don't know xml at all. I just plug things in where you folks tell me to.
roglen is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-27-2010, 06:15 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Quote:
Originally posted by roglen
Typed it in the macro as you had in your instructions:

/show_window custom.eq2_ToonSwap

Aslo tried: /show_window Custom._eq2_ToonSwap... nothing

When I run the macro ingame I get nothing at all, no command error, no nothing. Its just like I did not run the macro.

I copied the ToonSwap folder to the images folder, and to double check I copied the files in the toonswap folder to the images folder... nothing. The _eq2_ToonSwap.xml is in my ui folder and <include>_eq2_ToonSwap.xml</include> is in my eq2ui_custom.xml.

All of my char names are first letter cap just as the Char1 Char2 etc etc...

Got me...LOL
OMG I am at a complete loss I see absolutely nothing wrong. Mine still works fine and as far as I can tell its identical setup to yours. Can you check your UI log file for any clues? It is directly in the eq2 folder, I usually use that when a UI wont load. I assume when u say the _eq2_ToonSwap.xml is in my ui folder you mean the DrumsUI folder?

Oh with the UI file in the eq2 folder if there is too much there just delete it and run eq2 and a new one will be created

Last edited by Wyntakata : 05-27-2010 at 06:20 PM.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-27-2010, 01:53 PM  
roglen
A Coastal Crab
 
roglen's Avatar

Server: Antonia Bayle
Forum posts: 1
File comments: 9
Uploads: 0
Quote:
Originally posted by Wyntakata
Just thought of something Roglen. What you type in all the files and the macro is case sensitive so be sure you typed exactly as I did.
Typed it in the macro as you had in your instructions:

/show_window custom.eq2_ToonSwap

Aslo tried: /show_window Custom._eq2_ToonSwap... nothing

When I run the macro ingame I get nothing at all, no command error, no nothing. Its just like I did not run the macro.

I copied the ToonSwap folder to the images folder, and to double check I copied the files in the toonswap folder to the images folder... nothing. The _eq2_ToonSwap.xml is in my ui folder and <include>_eq2_ToonSwap.xml</include> is in my eq2ui_custom.xml.

All of my char names are first letter cap just as the Char1 Char2 etc etc...

Got me...LOL

Last edited by roglen : 05-27-2010 at 01:56 PM.
roglen is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-25-2010, 04:31 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Quote:
Originally posted by Wyntakata
Ok I see nothing wrong and I also use DrumsUI without issues so dont think its a conflict there.

Tell me what happens when you click the macro button you created ingame? also check the command in the macro to be sure no mistakes.
Just thought of something Roglen. What you type in all the files and the macro is case sensitive so be sure you typed exactly as I did.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-25-2010, 12:33 PM  
Wyntakata
A Brown Bear
 
Wyntakata's Avatar
Interface Author - Click to view interfaces

Server: Crushbone
Forum posts: 10
File comments: 44
Uploads: 3
Quote:
Originally posted by roglen
<?xml version="1.0" encoding="utf-8"?>
<Page IgnoreTab="false" ismodule="true" Name="Custom" PackSize="1,1" PackSizeProp="0002/0003,0002/0003" ScrollExtent="1024,768" Size="1024,768" Visible="false">
<include>_ProfitUI_SubClassDetector.xml</include>
<include>_ProfitUI_Styles.xml</include>
<include>eq2ui_custom_infocenter.xml</include>
<include>InfoCenter/includes.xml</include>
<include>DrumsUI/Settings/DrumsUI_ClickButtonSettings.xml</include>
<include>DrumsUI/Settings/DrumsUI_PlayerCureWindow.xml</include>
<include>DrumsUI/Settings/DrumsUI_TextSettings.xml</include>
<include>_eq2_ToonSwap.xml</include>
</Page>
Ok I see nothing wrong and I also use DrumsUI without issues so dont think its a conflict there.

Tell me what happens when you click the macro button you created ingame? also check the command in the macro to be sure no mistakes.
Wyntakata is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 11:36 AM.


Our Network
EQInterface | EQ2Interface | War.MMOUI | WoWInterface | VGInterface | LoTROInterface | MMOInterface