Quantcast
EQ2Interface.com
Search Downloads


Go Back   EQ2Interface > Interface Pieces > Miscellaneous

Category: Miscellaneous[DragowulfUI] Auto Attack Timer
Interface Information
Download
dragowulf's Portal Bug Reports Feature Requests
How do I install this? (FAQ)
Name: [DragowulfUI] Auto Attack Timer   Popular!
Author:
Date: 08-08-2009 07:50 PM
Size: 1.94 Kb
Version: V1.3 2009.08.08
Rate Addon: 5 out of 5 with 6 votes  
Pictures
Click to enlarge 

Views: 0
Size: 2.24 Kb
Dimensions: 380 x 67
 
Description
Game Update #52 Compatible


Description:
This custom window functions as an auto attack timer for your Primary, Secondary, and Ranged weapons. The main purpose of this window is to give the user visual aid in timing their auto attacks for maximum DPS output. Other functionalities include, but are not limited to: horizontal resizeability, vertical resizeability that allows the user to hide the Secondary bar if so chosen, the Secondary bar does not remain visible when the Primary/Secondary delays are both the same, the auto attack bars turn red while you're casting, and the auto attack bars become tinted when auto attack is changed/disabled during an auto attack.


Installation Notes:
- How To: Install A Custom UI
- eq2ui_custom_dragowulfui_autoattacktimer.xml goes in your CustomUI folder.
- If you do not have eq2ui_custom.xml, copy it from your EverQuest II/UI/Default folder and paste it in your CustomUI folder.
- Open the file with a text editor and replace all text with:
Code:
<?xml version="1.0" encoding="utf-8"?>
<Page IgnoreTab="false" ismodule="true" Name="Custom" PackSize="1,1" PackSizeProp="0002/0003,0002/0003" ScrollExtent="1024,768" Size="1024,768" Visible="false">
<include>eq2ui_custom_dragowulfui_autoattacktimer.xml</include>
</Page>
- If you already have eq2ui_custom.xml, open it with a text editor and add the following line:
Code:
<include>eq2ui_custom_dragowulfui_autoattacktimer.xml</include>
- It will then look something like this (make sure the line you're adding is the line under the second line of eq2ui_custom.xml and not on the last line of the .xml):
Code:
<?xml version="1.0" encoding="utf-8"?>
<Page IgnoreTab="false" ismodule="true" Name="Custom" PackSize="1,1" PackSizeProp="0002/0003,0002/0003" ScrollExtent="1024,768" Size="1024,768" Visible="false">
<include>eq2ui_custom_dragowulfui_autoattacktimer.xml</include>
</Page>
** WARNING: Please verify that you correctly followed the Installation Notes above, otherwise several issues will occur. **


Update Log:
V1.3 2009.08.08
- Added a new feature that turns the auto attack bars red while you're casting


V1.2 2009.08.07
- Fixed a bug that caused the window to still be visible upon switching between Melee/Ranged auto attacks and then suddenly turning auto attack off

V1.1 2009.08.06
- Changed the color of the bars

V1.0 2009.08.06
- Initial release
Archive List (Old Versions)
File Name
Version
Size
Author
Date
V1.2 2009.08.07
1.80 Kb
dragowulf
08-07-2009 04:31 PM
V1.1 2009.08.06
1.80 Kb
dragowulf
08-06-2009 04:43 AM
V1.0 2009.08.06
15.94 Kb
dragowulf
08-06-2009 03:11 AM
File Statistics
User Rating:
5 out of 5 with 6 votes
Downloads: 10536
Views: 54161
Favorites: 30
Uploaded By:
 
Last Modified: 08-09-2009 05:01 PM by dragowulf    

View Pictures. Download Now! Post A Comment


Post A Reply
Author Comments Comment Options
Unread 11-05-2011, 07:43 PM  
AKK123
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
ok so I found a way to send the read-only file out of the folder, so now I have the customui.xml and the custom_drag (etc etc) file only my customui folder...but it STILL isnt working!

For the "customui" folder, does it HAVE to be named customui or can it be anything? By the way, I'm assuming the customui folder is the same thing as the interface folder? (One you create and put into UI folder?)
AKK123 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-05-2011, 07:22 PM  
AKK123
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
still not working for me

For some reason the autoattack bar refuses to show up for me. I'm unsure of what I am doing wrong...but I'll write what i did

1. downloaded file
2. extracted file
3. copy/pasted into custom ui folder (this is the UI folder)
4. went into UI/Default and copy pasted eq2.custom.xml into custom ui folder.
5. deleted text in the eq2.custom.xml and replaced it with the text you had, but when I clicked saved it said you cannot save over a "read-me" file...so it told me to make another file named eq2.customs.txt
6. made eq2.ini file with the code given

Did I mess up at step 5? When I downloaded the file at the beginning, I think I forgot to direct it to the custom UI folder so I just copy pasted it in there, which I think is fine.

Please tell me what's wrong! Really want this for by brig

Last edited by AKK123 : 11-05-2011 at 07:23 PM.
AKK123 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 04-14-2011, 07:17 AM  
Juravael
A Coastal Crab

Server: Antonia Bayle
Forum posts: 1
File comments: 27
Uploads: 0
Same here

Quote:
Originally posted by Warkral
My wife had this once, but when we got her new computer, we can't for the life of us get this thing to work. I've been trying for literally, 3 hours. The only thing I can figure it it WILL NOT WORK with the default UI? I can post pix if necessary. Please help.
I was trying to instal this today and same thing. I can not seem to get it to work. I am guessing because it is so out of date?
Juravael is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 03-14-2011, 05:39 PM  
Warkral
A Coastal Crab

Server: Antonia Bayle
Forum posts: 1
File comments: 1
Uploads: 0
My wife had this once, but when we got her new computer, we can't for the life of us get this thing to work. I've been trying for literally, 3 hours. The only thing I can figure it it WILL NOT WORK with the default UI? I can post pix if necessary. Please help.
Warkral is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-26-2010, 08:59 PM  
vhalinjranj
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
Re: timer vs map

Quote:
Originally posted by vhalinjranj
I followed the instructions for downloading/installing and got everything to work properly, except now my eq2map isnt working. How can I fix the ini file so that both mods work correctly?
Nevermind, I figured it out. I had to set up the ini file with my custom folder and then put all my map stuff in there instead of trying to run the two ui mods seperately.
vhalinjranj is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 10-26-2010, 08:45 PM  
vhalinjranj
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
timer vs map

I followed the instructions for downloading/installing and got everything to work properly, except now my eq2map isnt working. How can I fix the ini file so that both mods work correctly?
vhalinjranj is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-22-2010, 10:10 PM  
depeche179
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
Re: Problems getting UI to work

Quote:
Originally posted by depeche179
I don't know if it is vista causing the UI to not work or what the problem is... I followed the instructions and still no timer. Did the last update bug the UI? Any help would be appreciated. Thanks
Never mind I figured it out thanks now I am trying to figure out how it times the attacks.
depeche179 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-22-2010, 09:37 PM  
depeche179
A Coastal Crab

Server: Antonia Bayle
Forum posts: 0
File comments: 2
Uploads: 0
Problems getting UI to work

I don't know if it is vista causing the UI to not work or what the problem is... I followed the instructions and still no timer. Did the last update bug the UI? Any help would be appreciated. Thanks
depeche179 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-15-2009, 12:49 PM  
bannister99
A Young Mystail Rat

Server: Unkown
Forum posts: 5
File comments: 2
Uploads: 0
Your wrong Script.

But I did download yours as well . I messed around with Both. My setup somewhere, With where im Puting the coding ( if thats the right word) is wrong. Im missing something Basic, I think when reading the directions.

Haha I just want a Autoatack time for my Brig )
bannister99 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-09-2009, 08:18 AM  
dragowulf
A man among men
 
dragowulf's Avatar
Interface Author - Click to view interfaces

Server: Nagafen
Forum posts: 934
File comments: 247
Uploads: 20
Re: Cant get timer to work

Quote:
Originally posted by bannister99
snip
That's not my interface mod that you downloaded.
dragowulf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-07-2009, 07:19 PM  
bannister99
A Young Mystail Rat

Server: Unkown
Forum posts: 5
File comments: 2
Uploads: 0
Cant get timer to work

Hello ok cant get Autoattack timer to work.
This is the 1st UI change i have made other then Eq2 maps.

Here is what I have done so far.

Placed new folder in

C:\Users\wil\AppData\LocalLow\Sony Online Entertainment\Installed Games\EverQuest II Streaming\UI

Named RazcUI

Inside this folder is EQ2ui_custom With this Programing

<?xml version="1.0" encoding="utf-8"?>
<Page IgnoreTab="false" ismodule="true" Name="Custom" PackSize="1,1" PackSizeProp="0002/0003,0002/0003" ScrollExtent="1024,768" Size="1024,768" Visible="false">
<include>Razc_Attack.xml</include>
</Page>

and Raz_attack with The Unziped of your Program

<?xml version="1.0" encoding="utf-8"?>
<Page OnShow="Data.Visible=WC_Frame.Visible" eq2usescomwndcontrols="true" Location="806,591" MaximumSize="361,50" MinimumSize="150,34" Name="Attack" ScrollExtent="361,50" Size="361,50" UserMovable="true" UserResizable="true" version="3.0">

<ProgressbarStyle Bar.Background="progress_fill" Name="progress_style"/>
<ImageStyle Name="progress_fill">
<ImageFrame Name="progress_fill" Source="images/window_elements_generic.dds" SourceRect="221,483,379,489"/>
</ImageStyle>

<Page Name="Data" Text="Razieh>Lint>Gaige" Visible="False">
<Image OnHide="Parent.Parent.CombatCheck.Visible=False" OnShow="Show_Window Custom.Attack" DynamicData="/GameData.Self.IsHated" Name="IsHated" />
<Page Name="Pswitch" OnHide="Parent.Parent.Rcheck.Visible=True" OnShow="Parent.Parent.Mcheck.Visible=True" DynamicData="/GameData.Self.TimeSinceAutoAttack" />
<Page Name="Sswitch" OnHide="Parent.Parent.Rcheck.Visible=True" OnShow="Parent.Parent.Mcheck.Visible=True" DynamicData="/GameData.Self.TimeSinceSecondaryAutoAttack" />
<Page Name="Rswitch" OnHide="Parent.Parent.Mcheck.Visible=True" OnShow="Parent.Parent.Rcheck.Visible=True" DynamicData="/GameData.Self.TimeSinceRangedAutoAttack" />
<Text DynamicData="/GameData.Stats.Primary_Delay" Name="Pdelay" />
<Text OnTextChanged="Parent.Parent.SecondaryCheck.Visible=True" DynamicData="/GameData.Stats.Secondary_Delay" Name="Sdelay" />
</Page>

<Page Name="Rcheck" OnShow="BtempP=Parent.Data.Pswitch.Visible
BtempS=Parent.Data.Sswitch.Visible
Parent.RToggle.Visible=BtempP || BtempS
Parent.CombatCheck.Visible=Parent.Data.IsHated.Visible
Visible=False" Visible="False" />
<Page Name="RToggle" Onhide="Parent.RFix.Visible=Parent.Data.Rswitch.Visible
Visible=True" Visible="True" />
<Page Name="RFix" OnShow="Parent.Ranged.Visible=True
Parent.Melee.Visible=False
Visible=False" Visible="False" />

<Page Name="Mcheck" OnShow="BtempP=Parent.Data.Pswitch.Visible
BtempS=Parent.Data.Sswitch.Visible
Parent.MToggle.Visible=BtempP || BtempS
Parent.CombatCheck.Visible=Parent.Data.IsHated.Visible
Visible=False" Visible="False" />
<Page Name="MToggle" OnShow="Parent.MFix.Visible=Parent.Data.Rswitch.Visible
Visible=False" Visible="False" />
<Page Name="MFix" OnHide="Parent.Ranged.Visible=False
Parent.Melee.Visible=True
Parent.Melee.Primary.Visible=True
Parent.SecondaryCheck.Visible=True
Visible=True" Visible="True" />
<Page Name="SecondaryCheck" OnShow="BtempS=(Parent.Data.Sdelay.Text) '>' (0)
Parent.Melee.Secondary.Visible=BtempS
Parent.DWCheck.Visible=Parent.Data.Visible
Visible=False" Visible="False" />
<Page Name="DWCheck" OnShow="BtempC=(Parent.Data.Sdelay.Text) '!=' (Parent.Data.Pdelay.Text)
BtempS=(Parent.Data.Sdelay.Text) '>' (0)
BtempA=(BtempC == True)
BtempB=(BtempS == True)
BtempF=(BtempA == BtempB)
Parent.Melee.Secondary.Visible=BtempF
Visible=False" Visible="False" />

<Page Name="CombatCheck" OnHide="BtempP=Parent.Data.Pswitch.Visible
BtempS=Parent.Data.Sswitch.Visible
BtempR=Parent.Data.Rswitch.Visible
Parent.OOC.Visible=BtempP || BtempS || BtempR
Visible=True" Visible="True" />
<Page Name="OOC" OnHide="Hide_Window Custom.Attack
Visible=True" Visible="True" />

<Page Location="6,0" Visible="True" AbsorbsInput="false" Name="Ranged" PackSize="Absolute,Absolute" size="349,50">
<Text AbsorbsInput="false" Font="/TextStyles.Large.LargeStyle" Margin="1,0,2,2" Name="MLabel" PackSize="absolute,fixed" ScrollExtent="349,20" ShadowStyle="/ShadowStylesNew.OutlineDrop.style" Size="350,20" TextAlignment="Center" TextColor="#F0D080">Ranged Auto Attack</Text>
<Progressbar Color="#ff7e00" Visible="False" AbsorbsInput="false" BackgroundColor="#000000" Location="3,23" Name="OOC" PackSize="absolute,fixed" PackSizeProp="0012/0001,0002/0003" Progress="1.00" ScrollExtent="343,8" Size="343,8" Style="progress_style"/>
<Progressbar Onshow="Parent.OOC.Visible=False" Onhide="Parent.OOC.Visible=True" AbsorbsInput="false" BackgroundColor="#000000" DynamicData="/GameData.Self.TimeSinceRangedAutoAttack" Location="3,23" Name="Bar" PackSize="absolute,fixed" PackSizeProp="0012/0001,0002/0003" Progress="0.500" ScrollExtent="343,8" Size="343,8" Style="progress_style"/>
<Image AbsorbsInput="false" Location="3,23" Name="Bkg" PackSize="absolute,fixed" PackSizeProp="0006/0001,0002/0003" ScrollExtent="343,8" Size="343,8" SourceRect="220,472,380,478" SourceResource="/images/window_elements_generic.dds"/>
<Page AbsorbsInput="false" Location="0,20" BackgroundOpacity="1.000" Name="Frame" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" PackSize="absolute,fixed" PackSizeProp="0000/0001,0002/0003" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="349,14" Size="349,14"/>
</Page>
<Page Name="Melee" AbsorbsInput="false" PackSize="Absolute,Absolute" size="349,50" Location="6,0" Visible="True">
<Page AbsorbsInput="false" Name="Primary" PackSize="Absolute,Absolute" size="349,50">
<Text AbsorbsInput="false" Font="/TextStyles.Large.LargeStyle" Margin="1,0,2,2" Name="MLabel" PackSize="absolute,fixed" ScrollExtent="349,20" ShadowStyle="/ShadowStylesNew.OutlineDrop.style" Size="350,20" TextAlignment="Center" TextColor="#F0D080">Melee Auto Attack</Text>
<Progressbar Color="#ff7e00" Visible="False" AbsorbsInput="false" BackgroundColor="#000000" Location="3,23" Name="OOC" PackSize="absolute,fixed" PackSizeProp="0012/0001,0002/0003" Progress="1.00" ScrollExtent="343,8" Size="343,8" Style="progress_style"/>
<Progressbar Onshow="Parent.OOC.Visible=False" Onhide="Parent.OOC.Visible=True" AbsorbsInput="false" BackgroundColor="#000000" DynamicData="/GameData.Self.TimeSinceAutoAttack" Location="3,23" Name="Bar" PackSize="absolute,fixed" PackSizeProp="0012/0001,0002/0003" Progress="0.500" ScrollExtent="343,8" Size="343,8" Style="progress_style"/>
<Image AbsorbsInput="false" Location="3,23" Name="Bkg" PackSize="absolute,fixed" PackSizeProp="0006/0001,0002/0003" ScrollExtent="343,8" Size="343,8" SourceRect="220,472,380,478" SourceResource="/images/window_elements_generic.dds"/>
<Page AbsorbsInput="false" Location="0,20" BackgroundOpacity="1.000" Name="Frame" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" PackSize="absolute,fixed" PackSizeProp="0000/0001,0002/0003" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="349,14" Size="349,14"/>
</Page>
<Page AbsorbsInput="false" Name="Secondary" PackSize="Absolute,Absolute" size="349,50">
<Progressbar Color="#ff7e00" Visible="False" AbsorbsInput="false" BackgroundColor="#000000" Location="3,36" Name="OOC" PackSize="absolute,fixed" PackSizeProp="0012/0001,0002/0003" Progress="1.00" ScrollExtent="343,8" Size="343,8" Style="progress_style"/>
<Progressbar Onshow="Parent.OOC.Visible=False" Onhide="Parent.OOC.Visible=True" AbsorbsInput="false" BackgroundColor="#000000" DynamicData="/GameData.Self.TimeSinceSecondaryAutoAttack" Location="3,36" Name="Bar" PackSize="absolute,fixed" PackSizeProp="0012/0001,0002/0003" Progress="0.500" ScrollExtent="343,8" Size="343,8" Style="progress_style"/>
<Image AbsorbsInput="false" Location="3,36" Name="Bkg" PackSize="absolute,fixed" PackSizeProp="0006/0001,0002/0003" ScrollExtent="343,8" Size="343,8" SourceRect="220,472,380,478" SourceResource="/images/window_elements_generic.dds"/>
<Page AbsorbsInput="false" Location="0,33" BackgroundOpacity="1.000" Name="Frame" PackLocation="top,left" PackLocationProp="0000/0001,0000/0001" PackSize="absolute,fixed" PackSizeProp="0000/0001,0002/0003" RStyleDefault="/rectlist.chat_bubble_frame" ScrollExtent="349,14" Size="349,14"/>
</Page>
</Page>

<Page Name="WC_Frame" Onshow="Parent.Data.Visible=True
Parent.SecondaryCheck.Visible=True" Onhide="Parent.Data.Visible=False
Parent.SecondaryCheck.Visible=True" RStyleDefault="/FrameStyles.single_pixel" PackSize="absolute,absolute" ScrollExtent="361,50" AbsorbsInput="false" Size="361,50" />
<Page AbsorbsInput="false" BackgroundOpacity="1.000" Name="WC_Backdrop" PackLocation="left,top" PackSize="absolute,absolute" ScrollExtent="361,50" Size="361,50" />

</Page>


I then created Eq2.ini

with

cl_ui_subdir UI/
cl_ui_skinname Razc


Please am i missing anything do I have to do anything ingame even to make it work.

Hope this all makes some sense .
Thanks in advance for your help )
bannister99 is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-20-2009, 03:35 PM  
dragowulf
A man among men
 
dragowulf's Avatar
Interface Author - Click to view interfaces

Server: Nagafen
Forum posts: 934
File comments: 247
Uploads: 20
Re: having issues

Quote:
Originally posted by felony
Hey guys looking to get this great option working.
I did as noted above for installation, Making a custom folder and copy paste the correct formula into a text document and reads as it should , Should the folder be in the directory or in the ui default folder?? Thanks
It should not be in the Default folder. It should look like: Everquest II/UI/-insert custom UI folder name here-
dragowulf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-20-2009, 02:15 PM  
felony
A Coastal Crab

Server: Antonia Bayle
Forum posts: 1
File comments: 1
Uploads: 0
having issues

Hey guys looking to get this great option working.
I did as noted above for installation, Making a custom folder and copy paste the correct formula into a text document and reads as it should , Should the folder be in the directory or in the ui default folder?? Thanks
felony is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-13-2009, 10:58 PM  
dragowulf
A man among men
 
dragowulf's Avatar
Interface Author - Click to view interfaces

Server: Nagafen
Forum posts: 934
File comments: 247
Uploads: 20
Quote:
Originally posted by adolf102
Awewsome mod!

Thanks a lot!
Now when I tried it I think it should be standard part of UI
I am glad you like it!
dragowulf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-13-2009, 01:14 PM  
adolf102
A Brown Bear
Interface Author - Click to view interfaces

Server: Runnyeye
Forum posts: 11
File comments: 15
Uploads: 5
Awewsome mod!

Thanks a lot!
Now when I tried it I think it should be standard part of UI
adolf102 is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 01:37 PM.


Our Network
EQInterface | EQ2Interface | War.MMOUI | WoWInterface | VGInterface | LoTROInterface | MMOInterface